nginx的spdy模块错误

分类栏目:用户体验 - 前端开发

1535

发布于 0 条评论

就在刚刚,我编译nginx的时候,突然得到了一条坑爹的提示:

./configure: error: invalid option "--with-http_spdy_module"

不应该啊,应该有spdy模块啊,无意中想到会不会是新版本的问题。我升级的是1.9.5..

于是找到官方文章看了一下,看到下面这段:

The ngx_http_v2_module module (1.9.5) provides support for HTTP/2 and supersedes thengx_http_spdy_module module.
This module is not built by default, it should be enabled with the --with-http_v2_moduleconfiguration parameter.

把--with-http_spdy_module换成--with-http_v2_module之后重新编译通过...

附上NGINX官方说明:http://nginx.org/en/docs/http/ngx_http_v2_module.html

评论列表